Resolving cloning issues in Indoor Mapping instances

  • Release version: Zurich
  • Updated July 7, 2026
  • 2 minutes to read
  • After cloning a Indoor Mapping source instance to a target instance, workplace administrators may observe missing attachments and data discrepancies in their target instance.

    Symptom

    Administrators can clone a source Indoor Mapping instance to a target Indoor Mapping instance. For more information, see cloning an instance.

    Before cloning your Indoor Mapping source instance to a target instance, preserve data for each of the listed tables in your source instance. This helps in preventing missing data and attachments in your target Indoor Mapping cloned instance tables.

    Cause

    Data discrepancies and missing attachment issues are observed after you have cloned your target instance. The System Clone [clone_instance] record or Clone Request [sn_instance_clone_request] record in the source instance excludes the Attachment [sys_attachment] table and doesn't preserve data in the Font [sn_map_core_font], Layer [sn_map_core_layer], Outdoor style [sn_map_core_outdoor_style], and Tile [sn_map_core_tile] tables.These issues also affect workplace experiences in Indoor Mapping Map Studio, Workplace Central, Workplace Reservation Management portal, Workplace Services Kiosk, Workplace Move Management, and Workplace Service Delivery for Mobile.

    Resolution

    Procedure

    1. Log in to your source instance.
    2. Export the list of records in each listed table as XML from the source instance:
      • sn_map_core_font
      • sn_map_core_outdoor_style
      • sn_map_core_layer
      • sn_map_core_tile

      For more information, see Export data from a list.

    3. Log in to the target instance.
    4. In the target instance, update your application scope to Indoor Mapping.
    5. Import the XML files to the target instance.
      Note:
      After importing the XML files, it's observed sometimes that there's no data in the JSON files. The JSON files stored in the Styles (style) column of the Outdoor styles [sn_map_core_outdoor_style] show missing attachments. To prevent missing attachments and data discrepancies, perform steps 6-7.

      For more information about how to import XML files, see Import data from XML.

    6. To avoid future clone issues, preserve data in the following tables:
      • sn_map_core_font
      • sn_map_core_outdoor_style
      • sn_map_core_layer
      • sn_map_core_tile
    7. To preserve data in sn_map_core_font, sn_map_core_outdoor_style, sn_map_core_layer, and sn_map_core_tile tables perform the following steps:
      1. Log in to your source Indoor Mapping instance.
      2. Navigate to All > Clone Admin Console > Clone Definition > Preserve data.
      3. Select New.
      4. On the form, fill in the fields:
        Table 1. Preserve Data form
        Field Description
        Table Enter the following table information as required:
        • [sn_map_core_font]
        • sn_map_core_layer
        • sn_map_core_outdoor_style
        • sn_map_core_tile
      5. Right-click the form header and select Save.
      6. Add your clone profiles.
        1. Navigate to Clone profiles related list.
        2. Select Edit.
        3. From the Collection slush bucket, add your clone profile(s) to the Clone Profile List slush bucket.
        4. Select Save.