Discovery ECC Queue Missing or Empty
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
37m ago
Hi everyone.
I'm hoping someone can help me as I haven't been able to find any results online and the remediation steps for the error aren't applicable. I'm getting semi-regular occurrences of the error "Discovery ECC Queue Missing or Empty" which has the refined code of SN-DISC-3888.
The root cause is stated as "The ECC Queue records for Discovery are missing or have been deleted from the ecc_queue table." and the remediation steps are as follows:
- Navigate to the discovery_status table and verify that the ECC Queue Related List on the affected Discovery Status records is populated with corresponding entries from the ecc_queue table.
- If the ECC Queue Related List is empty, go to the discovery_schedule table and rerun the corresponding Discovery Schedule(s) to regenerate and populate the missing ECC Queue records in the ecc_queue table.
- After the Discovery Schedule completes, rerun troubleshooting via Discovery Admin by selecting the recently run Discovery Status records.
When I follow them, step 1 always shows the ECC Queue related list as being populated, meaning there's no action for me to take on step 2. I can't find a pattern between which schedules/devices are producing an error. I initially thought it might be due to the structure of my Range Sets/IP Ranges which I've got setup like so:
- Site A - Floor 0 (Range Set)
- 1000 IPs (IP Range)
- Site A - Floor 1 (Range Set)
- 1000 IPs (IP Range)
- Site A - Floor 2 (Range Set)
- 1000 IPs (IP Range)
- VPN A (Range Set)
- 8000 IPs (IP Range)
- VPN B (Range Set)
- 4000 IPs (IP Range)
I'm happy to split those IP Ranges out to make them smaller but I'm (occasionally) getting the error on a schedule which contains a single IP for testing so I'm not sure that the size of the IP Ranges in those Range Sets is the issue. The CIs are actually getting updated correctly every time and I can see the entries in the ECC Queue, these look to be identical when comparing a Discovery Status that produced the error and one that did not. If I click on the error I can select "Retry Discovery" for each entry and generally that fixes it but that's a bit tedious and not a long term solution.
Any suggestions here would be really appreciated. Let me know if you need anymore information.
