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01-19-2023 12:12 AM - edited 01-19-2023 12:14 AM
Hi All,
Im having problem with AI Search. Whenever Im searching on to the typeheadsearch. And clicking one of the search result that is a knowledge article.
It redirects me to knowledge article page but "sys_id" from url parameter is undefined
Anyone else having the same problem?
Solved! Go to Solution.
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01-27-2023 05:13 AM
Found the solution, try Service Portal> Ai search> Search result action
then add your portal to the records needed
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02-06-2023 01:32 PM
We're experiencing the same issue unexpectedly as well. We have "View Article" Search Result Actions already properly configured, and AI Search/Knowledge base links were functioning correctly until recently. It's unclear yet if recently activating Manager Hub led to AI Search > Articles breaking, or if it was caused by something else.
We're running:
- Employee Center 27.0.4
- Employee Center Core 27.0.5
- Employee Center Pro 27.0.2
- Manager Hub 1.0.0
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08-16-2023 06:07 AM
Knowledge articles not redirecting to kb_article page - Support and Troubleshooting (servicenow.com)
Description
In AI search-enabled portal, when clicking on generated suggested results for knowledge articles, users are being redirected to page id=form with sys_id as undefined in url for custom portals. This happens after upgrade to employee center pro version 27.0.2
Cause
After upgrading to employee center pro version 27.0.2, a new record of Knowledge search results is created in EVAM config definition for OOB
<https://<Instance>.service-now.com/nav_to.do?uri=sys_ux_composite_data_template_predicate_bundle.do?sys_id=34e7294753571010069addeeff7b1222
This is using ec_navigation declarative action. For the custom portal we will define navigation as action name which is OOB available action before upgrade.
Resolution
Update the action name to ec_navigation for custom portal in sp_ai_search_results_action_config table and update the payload query parameters similar to OOB employee center record.